Template Maps/ Einzelene Position je Artikel

Mehr
28 Okt 2014 14:46 #1844 von wuron
wuron antwortete auf das Thema: Template Maps/ Einzelene Position je Artikel
Ich habe nun auch das address to coordinates plugin eingebaut. Läuft nun auch. Erst hatte ich bei den 2 Feldern long und lat die Speicherung auf Benutzerdefiniert gestellt. Funktionierte nicht. Im SEBLOD® com Forum habe ich gefunden, dass man die Speicherung auf standard stellen soll. Nun läuft es.

Die index.php hatte ich kurz eingebaut. Ich bekam jedoch nicht das gewünschte Ergebnis. Aber das lag vielleicht an meinen fehlenden Koordinaten.

Ich probiere es nochmal aus. Wäre schön wenn ich das so zum Laufen bekomme.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
28 Okt 2014 15:01 #1845 von gebeer
gebeer antwortete auf das Thema: Template Maps/ Einzelene Position je Artikel
Wenn Du noch Fragen zur index.php hast, lass mich wissen.
Bin grade in Reisevorbereitung und hab nicht viel Zeit. Erst ab dem WE wieder.
Folgende Benutzer bedankten sich: wuron

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
29 Okt 2014 07:21 #1846 von wuron
wuron antwortete auf das Thema: Template Maps/ Einzelene Position je Artikel
Hi, ich habe nun die index.php eingebaut. Jedoch funktioniert es nicht wie erhofft. Ich lande in Australien und wenn ich die Suche einschränke dann wird gar keine Karte mehr angezeigt. Muss man nach dem einfügen noch irgendetwas ändern damit es funktioniert?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
13 Nov 2014 10:39 #1931 von wuron
wuron antwortete auf das Thema: Template Maps/ Einzelene Position je Artikel
Ich habe es nun nochmals probiert und nun funktioniert es. Top! Echt super!

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
13 Nov 2014 10:44 #1932 von gebeer
gebeer antwortete auf das Thema: Template Maps/ Einzelene Position je Artikel
Super, freut mich, das es geklappt hat. Sorry, dass ich nicht geantwortet hatte. Ich war auf Reisen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
13 Nov 2014 13:21 #1933 von wuron
wuron antwortete auf das Thema: Template Maps/ Einzelene Position je Artikel
Kein Problem! Beim rumprobieren lernt man ja auch ;)

Ich habe noch ein Problem mit der MAP, vielleicht kennt das ja auch Jemand.

Wenn man 2 einträge mit den gleichen Koordinaten hat, dann wird nur einer auf der Karte dargestellt. Da ich auch nur den Ort als Adresse zulassen möchte wird es vorkommen, dass noch mehr einträge übereinanderliegen. Vielleicht gibt es dafür ja eine Lösung.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
12 Aug 2015 08:32 #3063 von Ole
Ole antwortete auf das Thema: Template Maps/ Einzelene Position je Artikel
Hallo Leute,
ich tüfftele schon die ganze Zeit mit der Map im Content rum. Nach dem ich hier das und die ganzen Querverweise gelesen habe, habe ich es nun auch endlich hin bekommen das die Map mit dem Aktuellen Pin im jeweiligen Content angezeigt wird.

Ich habe nur noch ein Problem:
Wenn ich die Map innerhalb von Tabs setze, dann wird die Karte nicht sauber angezeigt und sobald man drauf klickt oder eine Aktion macht, dann kommt eine 404.
Erst wenn ich die Map auf eine eigene Position z.B. Bottembody setze und sich dort keine Tabs befinden, dann funktioniert die Map wie gewünscht.

Hat das schon mal einer gehabt bzw. gelöst? Ich hätte die Map gerne in einem Reiter meiner Tabs.

Grüße

Ole

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
12 Aug 2015 09:57 - 12 Aug 2015 10:01 #3064 von gebeer
gebeer antwortete auf das Thema: Template Maps/ Einzelene Position je Artikel
@Ole

Das klingt sehr nach einem Javascript-Problem.

Du kannst mal mit der Firebug-Console schauen was es für Fehlermeldungen gibt und die hier posten.

Kannst Du etwas genauer beschreiben, was im Tab nicht richtig dargestellt wird? Evtl einen Screenshot anhängen.
Letzte Änderung: 12 Aug 2015 10:01 von gebeer.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
12 Aug 2015 10:58 #3066 von Ole
Ole antwortete auf das Thema: Template Maps/ Einzelene Position je Artikel
Das verstehe einer noch...

Wenn ich die Map in den TAB verschiebe sieht das ganze bei mir aus wie auf dem Bild. Es wird einfach eine graue Fläche angezeigt.
Als ich noch die Elemente (Streetview z.B.) eingeblendet hatte, konnte man das Männchen drüber ziehen und die Karte ist Teilweise angezeigt worden, wenn auch an einer falschen Position.



Ich habe mir jetzt mal Firebug für Chrome installiert...

Wenn ich jetzt diesen anschalte sehe ich keine Veränderungen und weiß auch nicht wo ich da Fehler angezeigt bekommen soll.

Aber wenn ich "Element untersuchen" mit Chrome einschalte, dann erscheint die Karte plötzlich. Schalte ich das wieder ab, dann bleibt die Karte auch sichtbar. Bei einem Reload ist sie wieder weg. Im Quelltext, kann ich nix besonders erkennen was fehlen könnte.
Anhang:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
12 Aug 2015 11:57 #3067 von gebeer
gebeer antwortete auf das Thema: Template Maps/ Einzelene Position je Artikel
Hi,
für Chrome hättest Du Firebug nicht installieren müssen (kannst Du also wieder deinstallieren). Chrome bringt seine eigene Debug-Konsole mit.
Einfach F12 drücken. In dem Fenster dass dann unten im Chrome erscheint auf "Konsole" klicken und Seite nochmal neu laden. Dann werden Dir evtl. Javascript-Fehler angezeigt. Probier das mal und poste das Ergebnis hier als Screenshot.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Powered by Kunena Forum