Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: SEBLOD® error table doesn't exist

SEBLOD® error table doesn't exist 26 Jun 2016 16:14 #3720

  • BiLe
  • BiLes Avatar
  • OFFLINE
  • Beiträge: 2
Hallo,

meine Frage passt nicht wirklich in einen Forenbereich bei euch, da es eher eine allgemeine Frage zu einer SEBLOD® Fehlermeldung ist. Ich habe diese Frage bereits in dem offiziellen SEBLOD® Forum gestellt, erhalte aber keine Antwort. Vielleicht können ihr mir ja helfen.

Frische Joomla 3.5.1 und aktuelles SEBLOD® installiert.

Für ein Feld in dem Bereich "List & Search Form" kann man ja den Storage Ort angeben...

Storage->Format/Object->Standard->User->id

Mehr geht es um den Eintrag "id" nach der Definition des tables. Dort kann man ja ein popup öffnen, welches mir alle verfügbaren Tabellen-Felder für eine Auswahl anzeigen sollte. Ich erhalte aber folgende Meldung in dem PopUp...

<<< An error has occurred. Table 'xxxxxxx_xx.#__user' doesn't exist SQL=SHOW COLUMNS >>>

Wird wohl mit dem Tabellenprefix zusammenhängen. Bei mir nennen sich die Tabellen "joomla_xxx", also für die Tabelle "User" würde sich die Tabelle "joomla_user" nennen. SEBLOD® scheint aber nach 2 Unterstrichen zu suchen.

Kann ich den Tabellen-Prefix irgendwo einstellen?

Gruß...
Der Administrator hat öffentliche Schreibrechte deaktiviert.

SEBLOD® error table doesn't exist 27 Jun 2016 12:16 #3721

  • time4mambo
  • time4mambos Avatar
  • OFFLINE
  • Mal gucken ob was passiert...
  • Beiträge: 903
  • Dank erhalten: 176
Das ist ein Platzhalter für die korrekte Suffix. Also die Raute plus dem ersten Unterstrich. Der zweite Unterstrich wird dann ja ohnehin von der Tabelle benötigt. Da jede Präfix in jeder Datenbank anders bestückt ist, wird hier eben dieser Platzhalter übergeben. Damit wird dann vom System (also Joomla) die zugehörige und eindeutige Präfix ermittelt.

Das ist also alles richtig soweit.

Die ID wird aber normalerweise automatisch erzeugt, in dem einfach ein Zähler bei Speicherung hoch gezählt wird. Vielleicht kannst du einfach in diesem Zusammenhang nicht speichern? Hast du dieses Problem denn auch noch an anderer Stelle?

Am Rande: bitte auch bei SEBLOD® einen Hinweis angegeben, dass du es hier auch diskutierst. So bindest du ansonsten mehrere Supporter, denn es ist ja nicht auszuschließen, dass da auch jemand über dein Problem nachdenkt. Ein gegenseitiges Verlinken der Beiträge sollte denn auch ein Muss sein!


Axel
Das SEBLOD®-Handbuch auf Amazon
Tutorials zu Joomla und MS-Office: www.time4joomla.de
Letzte Änderung: 27 Jun 2016 12:18 von time4mambo.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

SEBLOD® error table doesn't exist 27 Jun 2016 12:39 #3722

Hallo,

das Präfix ist global in Joomla! konfiguriert. SEBLOD® sucht also nicht nach 2 Unterstrichen. Das muss ein anderes Problem sein.

Du könntest uns, damit wir dir helfen können, einmal Screenshots senden und/oder die folgenden Fragen klären:
Was steht in den Fehlerlogs genau?
Konntest du den Table '#__user' normal aus der Tabellen-Spalte im Storage Bereich laden, also ist dies ein Dropdownfeld?
Sind auch alle SEBLOD® Plugins auf dem aktuellen Stand?

Ich bin grad nicht ganz sicher, denke aber, dass die Tabelle nach der du suchst, '#__users' anstatt '#__user' heisst...
prüf doch mal all dies ab und gib uns ein Feedback - auch wenn du den Fehler selber findest ;)

Beste Grüße,
Pierre Corell.
J!Praxis - Besser.Online - seit 2009
Joomla! Business Support, Programmierung, Websicherheit.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

SEBLOD® error table doesn't exist 04 Jul 2016 15:14 #3726

  • BiLe
  • BiLes Avatar
  • OFFLINE
  • Beiträge: 2
Hallo,

erst einmal Danke für eure nette Hilfe. Nach reichlichem testen (verschiedener Systeme) habe ich mich dazu entschieden auf Fabrik als RAD umzuschwenken.

Gruß...
Der Administrator hat öffentliche Schreibrechte deaktiviert.
nach oben