Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: Nach Datum sortieren ?

Nach Datum sortieren ? 29 Nov 2014 21:40 #2033

ich möchte eine Liste nach einem Datum-Feld sortieren. Wie bekomme ich das hin und wie muss das Feld eingestellt sein?

Herb
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Nach Datum sortieren ? 29 Nov 2014 23:30 #2035

  • time4mambo
  • time4mambos Avatar
  • OFFLINE
  • Mal gucken ob was passiert...
  • Beiträge: 902
  • Dank erhalten: 176
In dem du in der Liste dein Datumfeld in die Sortierung ziehst und auswählst, ob Aufsteigend oder Absteigend. Wo ist das Problem?


Axel
Das SEBLOD®-Handbuch auf Amazon
Tutorials zu Joomla und MS-Office: www.time4joomla.de
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: herbertchen

Nach Datum sortieren ? 30 Nov 2014 14:05 #2039

sortiert nicht -zumindest nicht erkennbar (siehe Anhang). Irgend etwas mache ich falsch.

meine Einstellung: Suchformular: cck, Sortierung: Geburtstag; Liste: Geburtstag + Name

Einstellung des Feldes Geburtstag als image anbei.

herb
Anhang:
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Nach Datum sortieren ? 30 Nov 2014 15:54 #2040

  • time4mambo
  • time4mambos Avatar
  • OFFLINE
  • Mal gucken ob was passiert...
  • Beiträge: 902
  • Dank erhalten: 176
Das funktioniert leider nicht mit einem Kalenderfeld. Mit einem einfachen Textfeld funktioniert es einwandfrei.


Axel
Das SEBLOD®-Handbuch auf Amazon
Tutorials zu Joomla und MS-Office: www.time4joomla.de
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: herbertchen

Nach Datum sortieren ? 30 Nov 2014 21:44 #2041

Habe jetzt auf Textfeld umgestellt, Ergebnis ist leider das Gleiche: keine sortierung, wie gehabt.
???
Wie muss ich denn das Suchfeld der Liste einstellen?

Herb
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Nach Datum sortieren ? 01 Dez 2014 05:09 #2042

  • jacxx
  • jacxxs Avatar
  • OFFLINE
  • Beiträge: 37
  • Dank erhalten: 2
Hast du schon mal im Menuiten, Options, Ordering geschaut..
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: herbertchen

Nach Datum sortieren ? 01 Dez 2014 10:04 #2043

Ja, da habe ich geschaut. Was mich jetzt aber stutzig macht, ich kann da einstellen,was ich will, es ändert sich nichts an der Sortierung :(
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Nach Datum sortieren ? 01 Dez 2014 11:43 #2044

  • time4mambo
  • time4mambos Avatar
  • OFFLINE
  • Mal gucken ob was passiert...
  • Beiträge: 902
  • Dank erhalten: 176
Bei mir funktioniert es. Hatte es extra nachgebaut, wegen dem Kalenderfeld.
Rein vorsichtshalber, da ich ja nicht weiß, wo du was wie gemacht hast:

1. Inhaltstyp --> Adminformular --> Textfeld mit Datum per Hand eintrgen
2. Suchliste --> Liste --> Ausgabe Datumfeld --> Sortieren: Datumfeld --> Wahlweise Auf- oder Absteigend

Wie gesagt: bei mir tuts das.


Axel
Das SEBLOD®-Handbuch auf Amazon
Tutorials zu Joomla und MS-Office: www.time4joomla.de
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: herbertchen

Nach Datum sortieren ? 01 Dez 2014 11:53 #2046

In welchem Format trägst Du das Datum ein?
Da ich die Angaben importiere liegen sie in der Form Y-m-d (2014-12-01) vor. Obs daran liegt?

Ich hab das jetzt mal mit einigen Testdaten probiert, von Hand eingetragen, Format: d.m.Y

wird nicht nach Datum sortiert. Anzeige erfolgt in der Reihenfolge der Einträge, aufsteigend oder absteigend.

herbi-ratlos
Letzte Änderung: 01 Dez 2014 13:06 von herbertchen.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Nach Datum sortieren ? 01 Dez 2014 21:51 #2052

  • time4mambo
  • time4mambos Avatar
  • OFFLINE
  • Mal gucken ob was passiert...
  • Beiträge: 902
  • Dank erhalten: 176
In einem Textfeld gibt es kein Format. Aber ich habe so eingegeben, wie du es beschreibst. Siehe die Fotostrecke:


sebdatum01.jpg



sebdatum02.jpg



sebdatum03.jpg
Das SEBLOD®-Handbuch auf Amazon
Tutorials zu Joomla und MS-Office: www.time4joomla.de
Der Administrator hat öffentliche Schreibrechte deaktiviert.
nach oben