Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: Felder nicht zu speichern

Felder nicht zu speichern 14 Jul 2015 23:43 #2997

  • compep
  • compeps Avatar
  • OFFLINE
  • Beiträge: 25
  • Dank erhalten: 4
Hallo,

ich habe folgendes Problem: ich habe ein Formular angelegt mit ca. 25 Feldern. Es funktionierte auch alles wunderbar. Als ich dann aber das Formular aufteilen wollte auf mehrere Seiten (in Template bei Stages z.B. 4 Eingeben und dann entsprechend die einzelnen Felder zuordnen, klappte auch dies und es wurde im Frontend auch alles richtig angezeigt. Als ich dann einen Button einfügen wollte, war ab diesem Zeitpunkt das einfügen von Feldern nicht mehr möglich.
Ich konnte zwar ein neues Feld erstellen, als ich es aber dann zum Beispiel in den Mainbody ziehen wollte, ging das noch, aber nach dem speichern "sprang" dieses Feld wieder zurück auf die rechte Seite (im Anhang die Felder Test und Test1)
An was liegt das? Es hat sich auch nichts geändert, als ich die Einstellung mit den Seiten wieder auf 1 zurückgestellt habe. Das Formular wird im Frontend wieder normal dargestellt, also alle Felder auf einer Seite, aber es lassen sich keine Felder mehr anlegen,
Anhang:
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Felder nicht zu speichern 15 Jul 2015 07:26 #2999

  • time4mambo
  • time4mambos Avatar
  • OFFLINE
  • Mal gucken ob was passiert...
  • Beiträge: 913
  • Dank erhalten: 177
Das was du da schreibst, habe ich noch nie gesehen oder gehört. Da scheint bei dir was im Argen zu liegen. Welche Versionen von SEBLOD® und Joomla benutzt du denn? Mit "Button" einfügen meinst du ein Feld oder wovon genau sprichst du? Wenn alles richtig war und einwandfrei lief - wozu dient dann der Button genau?


Axel
Das SEBLOD®-Handbuch auf Amazon
Tutorials zu Joomla und MS-Office: www.time4joomla.de
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Felder nicht zu speichern 15 Jul 2015 07:51 #3001

  • compep
  • compeps Avatar
  • OFFLINE
  • Beiträge: 25
  • Dank erhalten: 4
Hallo Axel,

ich verwende jeweils die neuesten Versionen, SEBLOD® 3.6.2 und Jooml 3.4.3.
Ich habe ganz normal ein Formular mit recht vielen Feldern erstellt. Ich wollte das dann auf mehrere Seiten verteilen, also 3-4 Formularfelder und dann einen Button "weiter" einfügen. Wie gesagt, mir ist klar, wie das funktioniert, man legt bei Formulare und Inhaltstypen im Reiter template die Anzahl der Seiten fest, ordnet dann die Formularfelder entsprechend den Seiten zu. Um nun einen "Weiter"-Button einzufügen, erstelle ich im Seitenforrmular ein neues Feld, in dem ich die entsprechende Auswahl treffe. (AllAppFolders, AllContentTypes, AllTypes und B). Es erscheint eine Liste mit Buttons next. Wenn ich den z.B. in den Mainbody rüberziehe, bleibt er zunächst da, nach dem Speichern ist er aus dem Mainbody wieder verschwunden und befindet sich wieder auf der rechten Seite (ich weiß nicht, wie dieser Bereich in der Fachsprache heißt)
Seitdem ich das gemacht habe, kann ich kein Feld mehr einfügen, was sich allerdings nur auf mein Formular beschränkt. Wenn ich ein bestehendes Formularfeld in einen anderen Bereich des Templates ziehe, fünktioniert das aber.
Kann es sein, dass die Anzahl an Feldern limitiert ist?
Übrigens kann ich in anderen Formularen sehr wohl neue Felder erstellen, es scheint also weder an Joomla, noch an SEBLOD® zu liegen. Es muss irgendwas an den Einstellungen des Formulars passiert sein.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Felder nicht zu speichern 15 Jul 2015 07:58 #3002

  • time4mambo
  • time4mambos Avatar
  • OFFLINE
  • Mal gucken ob was passiert...
  • Beiträge: 913
  • Dank erhalten: 177
Gehe mal im Forum auf die Suche nach MAX Felder oder sowas in der Art. Es gibt dazu verschiedene Beiträge und Lösungsansätze. Eventuell findest du auch was über die "Lösungen" hier im Forum. Habs grad auch nicht auf dem Schirm... Aber es gibt bei manchen tatsächlich Probleme durch falsche Servereinstellungen.


Axel
Das SEBLOD®-Handbuch auf Amazon
Tutorials zu Joomla und MS-Office: www.time4joomla.de
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Felder nicht zu speichern 15 Jul 2015 11:16 #3004

  • compep
  • compeps Avatar
  • OFFLINE
  • Beiträge: 25
  • Dank erhalten: 4
Hallo Axel,

das Problem wurde gelöst. Mein Provider hat diese Einstellungen geändert und siehe da, schon funktionierts. max_input_vars wurde von 1000 auf 5000 hochgesetzt. Das musste ich über den Provider machen, da ich keine php.ini erstellen kann und über eine .htaccess war es auch nicht möglich.
Der Administrator hat öffentliche Schreibrechte deaktiviert.
nach oben