Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: Buttons in Form

Buttons in Form 09 Nov 2014 00:12 #1912

  • IP
  • IPs Avatar
  • OFFLINE
  • Beiträge: 1
Hallo Leute!

Ich habe seit 2 Wochen mit den SEBLOD® herumprobiert, denn ich wollte ein eigenes Formular und Listen erstellen. Fast geschafft.
Ich habe ein Formular gestalten mit dem die User verschieder besuchten Veranstaltungen eintragen können und diese in einer Liste angezeigt werden.
Seit Tagen stehe aber vor einem schweren Problem.
Die Buttons für "Cancel", "Save", "Save und Views", führen nicht zum erwünschten Ergebniss, wie z.B.
beim "Save und Close" nach dem Klick nicht auf die Seite führt (das Speichern funktioniert allerdings), worauf ich geglaubt habe, einzustellen (mittels " Redirection"..., sondern meldet das gespeichert wurde aber bleibt auf die gleichen Seite (Frontend)
Im Backend ist das kein Problem.

Das 2. Problem ist folgendes:
Die Liste zeigt entweder alle Veranstaltungen (ich habe auf 200) oder nur die Anzahl, gemäß Einstellung "Count" aber nicht mehr wenn man auf dem Link View All anklickt. Wo gibt es da noch was einzustellen, dass z.B nur die ersten 5 Veranstaltungen anzeigt obwohl mehrere gibt und alle angezeigt werden wenn ich auf den genannten Button anklicke. Anmerkung: ich habe keine Searchfunktionin dieser Liste vorgesehen. Ist das eine Vorausetzung dafür?

Ich wäre dankbar für Ratschläge.
Anhang:
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Buttons in Form 03 Jun 2015 12:46 #2900

  • Cappu
  • Cappus Avatar
  • OFFLINE
  • Beiträge: 146
  • Dank erhalten: 29
Habe hier bei einer SEBLOD®-Installation ebenfalls das Problem, das auf einer mehrsprachigen Seite nach dem Speichern das Redirect nicht mehr funktioniert.
Formular URL:
/de?option=com_cck&view=form&layout=edit&type=container&id=395&Itemid=245&return=aHR0cDovL3d3dy5hY2tlci1jb250YWluZXIuY29tL2RlL2JhdXN5c3RlbWUvZWluemVsY29udGFpbmVyL2dydW5kbW9kZWxs

Nach Speichern oder Speichern/Schließen lande ich auf folgender Seite:
de/component/cck

Was läuft hier falsch. Danke für jeden Tipp.

Gruß, Bernhard
Der Administrator hat öffentliche Schreibrechte deaktiviert.
nach oben